<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Is Sunrun Inc. (RUN) optimistic regarding its short-term prospects? | US Post News</title>
    <meta charset="UTF-8"/>
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.uspostnews.com/xmlrpc.php"/>
    <meta name='robots' content='max-image-preview:large'/>
<meta property="og:image" content="https://www.uspostnews.com/wp-content/uploads/2019/03/11.jpg"/><link rel="icon" type="image/png" href="https://uspostnews.com/wp-content/uploads/2019/02/33551.jpg"><link rel="amphtml" href="https://www.uspostnews.com/2021/04/12/is-sunrun-inc-run-optimistic-regarding-its-short-term-prospects/amp/"/><meta name="generator" content="AMP for WP 1.0.60"/><link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="US Post News &raquo; Feed" href="https://www.uspostnews.com/feed/"/>
<link rel="alternate" type="application/rss+xml" title="US Post News &raquo; Comments Feed" href="https://www.uspostnews.com/comments/feed/"/>
<link rel="alternate" type="application/rss+xml" title="US Post News &raquo; Is Sunrun Inc. (RUN) optimistic regarding its short-term prospects? Comments Feed" href="https://www.uspostnews.com/2021/04/12/is-sunrun-inc-run-optimistic-regarding-its-short-term-prospects/feed/"/>
		<script type="text/javascript">window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.uspostnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script>
		<!-- uspostnews.com is managing ads with Advanced Ads --><script>advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();</script>
		<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-.1em!important;background:none!important;padding:0!important}</style>
	<link rel='stylesheet' id='wp-block-library-css' href='https://www.uspostnews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7' type='text/css' media='all'/>
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Merriweather+Sans%3A400%2C700%2C800%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%2C800%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900%2C800&#038;ver=9.5' type='text/css' media='all'/>
<link rel='stylesheet' id='td-theme-css' href='https://www.uspostnews.com/wp-content/themes/Newspaper/style.css?ver=9.5' type='text/css' media='all'/>
<link rel='stylesheet' id='td-theme-demo-style-css' href='https://www.uspostnews.com/wp-content/themes/Newspaper/includes/demos/business/demo_style.css?ver=9.5' type='text/css' media='all'/>
<script type='text/javascript' src='https://www.uspostnews.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.uspostnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://www.uspostnews.com/wp-json/"/><link rel="alternate" type="application/json" href="https://www.uspostnews.com/wp-json/wp/v2/posts/276838"/><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.uspostnews.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.uspostnews.com/wp-includes/wlwmanifest.xml"/> 
<meta name="generator" content="WordPress 5.7"/>
<link rel="canonical" href="https://www.uspostnews.com/2021/04/12/is-sunrun-inc-run-optimistic-regarding-its-short-term-prospects/"/>
<link rel='shortlink' href='https://www.uspostnews.com/?p=276838'/>
<link rel="alternate" type="application/json+oembed" href="https://www.uspostnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.uspostnews.com%2F2021%2F04%2F12%2Fis-sunrun-inc-run-optimistic-regarding-its-short-term-prospects%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://www.uspostnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.uspostnews.com%2F2021%2F04%2F12%2Fis-sunrun-inc-run-optimistic-regarding-its-short-term-prospects%2F&#038;format=xml"/>
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    
<!-- JS generated by theme -->

<script>var tdBlocksArray=[];function tdBlock(){this.id='';this.block_type=1;this.atts='';this.td_column_number='';this.td_current_page=1;this.post_count=0;this.found_posts=0;this.max_num_pages=0;this.td_filter_value='';this.is_ajax_running=false;this.td_user_action='';this.header_color='';this.ajax_pagination_infinite_stop='';}(function(){var htmlTag=document.getElementsByTagName("html")[0];if(navigator.userAgent.indexOf("MSIE 10.0")>-1){htmlTag.className+=' ie10';}if(!!navigator.userAgent.match(/Trident.*rv\:11\./)){htmlTag.className+=' ie11';}if(navigator.userAgent.indexOf("Edge")>-1){htmlTag.className+=' ieEdge';}if(/(iPad|iPhone|iPod)/g.test(navigator.userAgent)){htmlTag.className+=' td-md-is-ios';}var user_agent=navigator.userAgent.toLowerCase();if(user_agent.indexOf("android")>-1){htmlTag.className+=' td-md-is-android';}if(-1!==navigator.userAgent.indexOf('Mac OS X')){htmlTag.className+=' td-md-is-os-x';}if(/chrom(e|ium)/.test(navigator.userAgent.toLowerCase())){htmlTag.className+=' td-md-is-chrome';}if(-1!==navigator.userAgent.indexOf('Firefox')){htmlTag.className+=' td-md-is-firefox';}if(-1!==navigator.userAgent.indexOf('Safari')&&-1===navigator.userAgent.indexOf('Chrome')){htmlTag.className+=' td-md-is-safari';}if(-1!==navigator.userAgent.indexOf('IEMobile')){htmlTag.className+=' td-md-is-iemobile';}})();var tdLocalCache={};(function(){"use strict";tdLocalCache={data:{},remove:function(resource_id){delete tdLocalCache.data[resource_id];},exist:function(resource_id){return tdLocalCache.data.hasOwnProperty(resource_id)&&tdLocalCache.data[resource_id]!==null;},get:function(resource_id){return tdLocalCache.data[resource_id];},set:function(resource_id,cachedData){tdLocalCache.remove(resource_id);tdLocalCache.data[resource_id]=cachedData;}};})();var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];var td_animation_stack_effect="type0";var tds_animation_stack=true;var td_animation_stack_specific_selectors=".entry-thumb, img";var td_animation_stack_general_selectors=".td-animation-stack img, .td-animation-stack .entry-thumb, .post img";var td_ajax_url="https:\/\/www.uspostnews.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=9.5";var td_get_template_directory_uri="https:\/\/www.uspostnews.com\/wp-content\/themes\/Newspaper";var tds_snap_menu="";var tds_logo_on_sticky="";var tds_header_style="tdm_header_style_3";var td_please_wait="Please wait...";var td_email_user_pass_incorrect="User or password incorrect!";var td_email_user_incorrect="Email or username incorrect!";var td_email_incorrect="Email incorrect!";var tds_more_articles_on_post_enable="";var tds_more_articles_on_post_time_to_wait="";var tds_more_articles_on_post_pages_distance_from_top=0;var tds_theme_color_site_wide="#4db2ec";var tds_smart_sidebar="enabled";var tdThemeName="Newspaper";var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";var td_magnific_popup_translation_tNext="Next (Right arrow key)";var td_magnific_popup_translation_tCounter="%curr% of %total%";var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";var tdsDateFormat="l, F j, Y";var tdDateNamesI18n={"month_names":["January","February","March","April","May","June","July","August","September","October","November","December"],"month_names_short":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"day_names":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"day_names_short":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"]};var td_ad_background_click_link="";var td_ad_background_click_target="";</script>


<!-- Header style compiled by theme -->

<style>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</style>



<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.uspostnews.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.uspostnews.com/stocks-trading/",
                    "name": "Stocks Trading"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.uspostnews.com/2021/04/12/is-sunrun-inc-run-optimistic-regarding-its-short-term-prospects/",
                    "name": "Is Sunrun Inc. (RUN) optimistic regarding its short-term prospects?"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://www.uspostnews.com/wp-content/uploads/2019/02/33551.jpg" sizes="32x32"/>
<link rel="icon" href="https://www.uspostnews.com/wp-content/uploads/2019/02/33551.jpg" sizes="192x192"/>
<link rel="apple-touch-icon" href="https://www.uspostnews.com/wp-content/uploads/2019/02/33551.jpg"/>
<meta name="msapplication-TileImage" content="https://www.uspostnews.com/wp-content/uploads/2019/02/33551.jpg"/>
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>(adsbygoogle=window.adsbygoogle||[]).push({google_ad_client:"ca-pub-6166308950018215",enable_page_level_ads:true});</script>
	<meta name="google-site-verification" content="MruR0mfZY8zxvYBu7-IUmyFX1gL2HJKLqCvoMI7d9EM"/>
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-136511250-1"></script>
<script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}gtag('js',new Date());gtag('config','UA-136511250-1');</script>
</head>

<body class="post-template-default single single-post postid-276838 single-format-standard is-sunrun-inc-run-optimistic-regarding-its-short-term-prospects global-block-template-11 td-business td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Yahoo">
                <i class="td-icon-font td-icon-yahoo"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-33" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first menu-item-33"><a href="https://uspostnews.com/home/">Home</a></li>
<li id="menu-item-276660" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-276660"><a href="https://www.uspostnews.com/stocks-trading/">Stocks Trading</a></li>
<li id="menu-item-276661" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-276661"><a href="https://www.uspostnews.com/analyst-snapshot/">Analyst Snapshot</a></li>
<li id="menu-item-276662" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-276662"><a href="https://www.uspostnews.com/equities-market-summary/">Equities Market Summary</a></li>
<li id="menu-item-276663" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-276663"><a href="https://www.uspostnews.com/financial-scores/">Financial Scores</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://www.uspostnews.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off"/>
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <style>@media (max-width:767px){.td-header-desktop-wrap{display:none}}@media (min-width:767px){.td-header-mobile-wrap{display:none}}</style>
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            
		    <!--
		        Error: <strong class="td-wp-booster-title">wp_booster error:</strong><br>td_api_base::mark_used_on_page : a component with the ID: tdm_header_style_3 is not set.<br>/opt/bitnami/apps/wordpress/htdocs/wp-content/themes/Newspaper/includes/wp_booster/td_api.php (rara-error)
		    -->
		    
		    <!--
		        Error: <strong class="td-wp-booster-title">wp_booster error:</strong><br>td_api_base::get_key : a component with the ID: <b>tdm_header_style_3</b> Key: <b>file</b> is not set.<br>/opt/bitnami/apps/wordpress/htdocs/wp-content/themes/Newspaper/includes/wp_booster/td_api.php (rara-error)
		    -->
		    
		    <!--
		        Error: <strong class="td-wp-booster-title">wp_booster error:</strong><br>The path  of the tdm_header_style_3 header style not found. Did you disable a tagDiv plugin?<br>/opt/bitnami/apps/wordpress/htdocs/wp-content/themes/Newspaper/includes/wp_booster/td_api.php (rara-error)
		    -->
		    
            </div>

            
<div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.uspostnews.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Stocks Trading" class="entry-crumb" href="https://www.uspostnews.com/stocks-trading/">Stocks Trading</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Is Sunrun Inc. (RUN) optimistic regarding its short-term prospects?</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-276838" class="post-276838 post type-post status-publish format-standard has-post-thumbnail hentry category-stocks-trading tag-nasdaq-run tag-run tag-run-stock tag-run-stock-price tag-sunrun" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a href="https://www.uspostnews.com/stocks-trading/">Stocks Trading</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Is Sunrun Inc. (RUN) optimistic regarding its short-term prospects?</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.uspostnews.com/author/jose-robinson/">Jose Robinson</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2021-04-12T11:11:19+00:00">April 12, 2021</time></span>                                                        </div>

            </header>

        </div>

        

        <div class="td-post-content">

        <div class="td-post-featured-image"><a href="https://www.uspostnews.com/wp-content/uploads/2019/03/11.jpg" data-caption=""><img width="696" height="457" class="entry-thumb td-modal-image" src="https://www.uspostnews.com/wp-content/uploads/2019/03/11-696x457.jpg" srcset="https://www.uspostnews.com/wp-content/uploads/2019/03/11-696x457.jpg 696w, https://www.uspostnews.com/wp-content/uploads/2019/03/11-300x197.jpg 300w, https://www.uspostnews.com/wp-content/uploads/2019/03/11-768x504.jpg 768w, https://www.uspostnews.com/wp-content/uploads/2019/03/11-1024x672.jpg 1024w, https://www.uspostnews.com/wp-content/uploads/2019/03/11-741x486.jpg 741w, https://www.uspostnews.com/wp-content/uploads/2019/03/11.jpg 1068w, https://www.uspostnews.com/wp-content/uploads/2019/03/11-640x420.jpg 640w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="11"/></a></div>
        <div class="uspos-amp-before-content" style="text-align: center; " id="uspos-106300716"><amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409" data-auto-format="rspv" data-full-width="">
  <div overflow=""></div>
</amp-ad></div><div class="uspos-before-content" style="" id="uspos-35201959"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6166308950018215" data-ad-slot="3110990055" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script>
</div>
<p>Sunrun Inc. (RUN) successfully pursues the sales of solar-powered residences on a long-term installment plan. Even though the segment&#8217;s share of revenue is growing, there are crucial features investors should be aware of.</p>



<p>The challenge of increasing sales of solar panels for homes has proven to be difficult due to the high price of the systems, which run from thousands to tens of thousands of dollars for bulky, stand-alone homes. California requires all new homes to have solar panels, but many users can find their electricity bills are reduced only with small systems.</p><div class="uspos-amp-2-para" style="text-align: center; " id="uspos-2047763703"><amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409" data-auto-format="rspv" data-full-width="">
  <div overflow=""></div>
</amp-ad></div><div class="uspos-content" style="text-align: center; " id="uspos-1458100797"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6166308950018215" data-ad-slot="3110990055" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script>
</div>



<p>It was solved by renting the panels from a stockpile for a short period before transferring ownership to the house owner. In a nutshell, the system is installed at no cost to the client and is then leased back to the customer for 20 years, at which time it becomes the owner&#8217;s property.</p>



<p>Convincing consumers that a solar plant is still valuable after 20 years was the most challenging part of this business model. Solar company Sunrun was able to cut their costs by citing panels with a 25-year guarantee and a pre-paid solar power plant&#8217;s advantages. A further factor for both parties is the availability of tax incentives for the use of green energy and its return to the grid.</p><div class="uspos-amp-4-para" style="text-align: center; " id="uspos-1944895112"><amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409" data-auto-format="rspv" data-full-width="">
  <div overflow=""></div>
</amp-ad></div>



<p>This business model turned out to be successful, despite criticism from skeptics, which indicates that consumers trust modern renewable energy technologies. From its 20-year solar rental program, Sunrun generated net assets of $ 2.54 billion out of a total of $ 4.17 billion.</p><div class="uspos-5th-para" style="text-align: center; " id="uspos-63000616"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6166308950018215" data-ad-slot="3110990055" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script>
</div>



<p>Sunrun&#8217;s decline in crediting costs can affect the Sunrun Inc. negatively, as some potential customers switch to more traditional, faster-purchasing panels. As a result, consumers are inclined to prefer digital loans since they come at a lower cost. Only the house&#8217;s early sale and its energy storage issue remain unsolved. Rather than renting batteries, loans are the preferred option for purchasing expensive batteries. Additionally, a solar system paid by loans is a definite selling point, whereas a system rented for another ten years, on the other hand, is an obstacle.</p><div class="uspos-amp-6-para" style="text-align: center; " id="uspos-1032689850"><amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409" data-auto-format="rspv" data-full-width="">
  <div overflow=""></div>
</amp-ad></div><div class="uspos-content-2" style="" id="uspos-177286370"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6166308950018215" data-ad-slot="4008945238" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script>
</div>



<p>More than 3.94 million Sunrun Inc. (RUN) shares were traded Friday at a closing price of $51.60, representing a dollar volume of approximately 3.94 million. The shares have shown negative weekly performance since 04/09/21, with a loss of almost -3.77%. Public ownership of common shares stands at 192.99M, of which 189.78M are traded.</p>
<div class="uspos-after-content" style="text-align: center; " id="uspos-1584519242"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6166308950018215" data-ad-slot="3110990055" data-ad-format="auto"></ins>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script>
</div><div class="uspos-amp-after-content" style="text-align: center; " id="uspos-1919892608"><amp-ad width="100vw" height="320" type="adsense" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409" data-auto-format="rspv" data-full-width="">
  <div overflow=""></div>
</amp-ad></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.uspostnews.com/tag/nasdaq-run/">NASDAQ: RUN</a></li><li><a href="https://www.uspostnews.com/tag/run/">RUN</a></li><li><a href="https://www.uspostnews.com/tag/run-stock/">RUN stock</a></li><li><a href="https://www.uspostnews.com/tag/run-stock-price/">RUN stock price</a></li><li><a href="https://www.uspostnews.com/tag/sunrun/">Sunrun</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.uspostnews.com/2021/04/12/is-sunrun-inc-run-optimistic-regarding-its-short-term-prospects/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.uspostnews.com%2F2021%2F04%2F12%2Fis-sunrun-inc-run-optimistic-regarding-its-short-term-prospects%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Is+Sunrun+Inc.+%28RUN%29+optimistic+regarding+its+short-term+prospects%3F&url=https%3A%2F%2Fwww.uspostnews.com%2F2021%2F04%2F12%2Fis-sunrun-inc-run-optimistic-regarding-its-short-term-prospects%2F&via=US+Post+News">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://www.uspostnews.com/2021/04/12/is-sunrun-inc-run-optimistic-regarding-its-short-term-prospects/">
                                        <div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
                                        <div class="td-social-but-text">Google+</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.uspostnews.com/2021/04/12/is-sunrun-inc-run-optimistic-regarding-its-short-term-prospects/&amp;media=https://www.uspostnews.com/wp-content/uploads/2019/03/11.jpg&description=Is+Sunrun+Inc.+%28RUN%29+optimistic+regarding+its+short-term+prospects%3F">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Is+Sunrun+Inc.+%28RUN%29+optimistic+regarding+its+short-term+prospects%3F %0A%0A https://www.uspostnews.com/2021/04/12/is-sunrun-inc-run-optimistic-regarding-its-short-term-prospects/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.uspostnews.com/2021/04/08/novavax-nvax-pfizer-pfe-or-moderna-mrna-who-will-be-the-new-vaccines-primary-beneficiary-against-covid-19-in-children/">Novavax (NVAX), Pfizer (PFE) or Moderna (MRNA): Who will be the new vaccine&#8217;s primary beneficiary against COVID-19 in children?</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.uspostnews.com/author/jose-robinson/">Jose Robinson</a></span></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Jose Robinson"></span><meta itemprop="datePublished" content="2021-04-12T11:11:19+00:00"><meta itemprop="dateModified" content="2021-04-12T11:11:21+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.uspostnews.com/2021/04/12/is-sunrun-inc-run-optimistic-regarding-its-short-term-prospects/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://uspostnews.com/wp-content/uploads/2019/02/3-300x101.png"></span><meta itemprop="name" content="US Post News"></span><meta itemprop="headline " content="Is Sunrun Inc. (RUN) optimistic regarding its short-term prospects?"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.uspostnews.com/wp-content/uploads/2019/03/11.jpg"><meta itemprop="width" content="1068"><meta itemprop="height" content="701"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_2_60742f50a871f_rand td_with_ajax_pagination td-pb-border-top td_block_template_11" data-td-block-uid="td_uid_2_60742f50a871f"><script>var block_td_uid_2_60742f50a871f=new tdBlock();block_td_uid_2_60742f50a871f.id="td_uid_2_60742f50a871f";block_td_uid_2_60742f50a871f.atts='{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_2_60742f50a871f_rand","td_column_number":3,"live_filter_cur_post_id":276838,"live_filter_cur_post_author":"14","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_2_60742f50a871f_rand","tdc_css_class_style":"td_uid_2_60742f50a871f_rand_style"}';block_td_uid_2_60742f50a871f.td_column_number="3";block_td_uid_2_60742f50a871f.block_type="td_block_related_posts";block_td_uid_2_60742f50a871f.post_count="3";block_td_uid_2_60742f50a871f.found_posts="44";block_td_uid_2_60742f50a871f.header_color="";block_td_uid_2_60742f50a871f.ajax_pagination_infinite_stop="";block_td_uid_2_60742f50a871f.max_num_pages="15";tdBlocksArray.push(block_td_uid_2_60742f50a871f);</script><h4 class="td-related-title td-block-title"><a id="td_uid_3_60742f50a9eb8" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_2_60742f50a871f" href="#">RELATED ARTICLES</a><a id="td_uid_4_60742f50a9ebd" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_2_60742f50a871f" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_2_60742f50a871f class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.uspostnews.com/2021/04/08/novavax-nvax-pfizer-pfe-or-moderna-mrna-who-will-be-the-new-vaccines-primary-beneficiary-against-covid-19-in-children/" rel="bookmark" class="td-image-wrap" title="Novavax (NVAX), Pfizer (PFE) or Moderna (MRNA): Who will be the new vaccine&#8217;s primary beneficiary against COVID-19 in children?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Novavax (NVAX), Pfizer (PFE) or Moderna (MRNA): Who will be the new vaccine&#8217;s primary beneficiary against COVID-19 in children?" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/03/13-218x150.jpg" width="218" height="150"/></a></div>                <a href="https://www.uspostnews.com/stocks-trading/" class="td-post-category">Stocks Trading</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2021/04/08/novavax-nvax-pfizer-pfe-or-moderna-mrna-who-will-be-the-new-vaccines-primary-beneficiary-against-covid-19-in-children/" rel="bookmark" title="Novavax (NVAX), Pfizer (PFE) or Moderna (MRNA): Who will be the new vaccine&#8217;s primary beneficiary against COVID-19 in children?">Novavax (NVAX), Pfizer (PFE) or Moderna (MRNA): Who will be the new vaccine&#8217;s primary beneficiary against COVID-19 in children?</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.uspostnews.com/2021/03/19/will-translate-bio-inc-tbio-find-a-support-level-soon/" rel="bookmark" class="td-image-wrap" title="Will Translate Bio Inc. (TBIO) Find a Support Level Soon?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Will Translate Bio Inc. (TBIO) Find a Support Level Soon?" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/03/p2-218x150.jpg" width="218" height="150"/></a></div>                <a href="https://www.uspostnews.com/stocks-trading/" class="td-post-category">Stocks Trading</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2021/03/19/will-translate-bio-inc-tbio-find-a-support-level-soon/" rel="bookmark" title="Will Translate Bio Inc. (TBIO) Find a Support Level Soon?">Will Translate Bio Inc. (TBIO) Find a Support Level Soon?</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.uspostnews.com/2021/03/16/here-is-how-cryptocurrency-become-more-important-to-the-profits-and-revenues-of-mastercard-ma/" rel="bookmark" class="td-image-wrap" title="Here is How Cryptocurrency Become More Important To The Profits And Revenues of MasterCard (MA)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="Here is How Cryptocurrency Become More Important To The Profits And Revenues of MasterCard (MA)" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/03/17-218x150.jpg" width="218" height="150"/></a></div>                <a href="https://www.uspostnews.com/stocks-trading/" class="td-post-category">Stocks Trading</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2021/03/16/here-is-how-cryptocurrency-become-more-important-to-the-profits-and-revenues-of-mastercard-ma/" rel="bookmark" title="Here is How Cryptocurrency Become More Important To The Profits And Revenues of MasterCard (MA)">Here is How Cryptocurrency Become More Important To The Profits And Revenues of MasterCard (MA)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_2_60742f50a871f" data-td_block_id="td_uid_2_60742f50a871f"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_2_60742f50a871f" data-td_block_id="td_uid_2_60742f50a871f"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
	<div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2021/04/12/is-sunrun-inc-run-optimistic-regarding-its-short-term-prospects/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.uspostnews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
				<div class="comment-form-input-wrap td-form-comment">
					<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
					<div class="td-warning-comment">Please enter your comment!</div>
				</div>
		        <div class="comment-form-input-wrap td-form-author">
			            <input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30" aria-required='true'/>
			            <div class="td-warning-author">Please enter your name here</div>
			         </div>
<div class="comment-form-input-wrap td-form-email">
			            <input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30" aria-required='true'/>
			            <div class="td-warning-email-error">You have entered an incorrect email address!</div>
			            <div class="td-warning-email">Please enter your email address here</div>
			         </div>
<div class="comment-form-input-wrap td-form-url">
			            <input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30"/>
                     </div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes"/><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<div class="gglcptch gglcptch_v2"><div id="gglcptch_recaptcha_240482565" class="gglcptch_recaptcha"></div>
				<noscript>
					<div style="width: 302px;">
						<div style="width: 302px; height: 422px; position: relative;">
							<div style="width: 302px; height: 422px; position: absolute;">
								<iframe src="https://www.google.com/recaptcha/api/fallback?k=6LcMIlIaAAAAAGyRyDb4A9xA0GgMPem8j_JohOMz" frameborder="0" scrolling="no" style="width: 302px; height:422px; border-style: none;"></iframe>
							</div>
						</div>
						<div style="border-style: none; bottom: 12px; left: 25px; margin: 0px; padding: 0px; right: 25px; background: #f9f9f9; border: 1px solid #c1c1c1; border-radius: 3px; height: 60px; width: 300px;">
							<textarea id="g-recaptcha-response" name="g-recaptcha-response" class="g-recaptcha-response" style="width: 250px !important; height: 40px !important; border: 1px solid #c1c1c1 !important; margin: 10px 25px !important; padding: 0px !important; resize: none !important;"></textarea>
						</div>
					</div>
				</noscript></div><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment"/> <input type='hidden' name='comment_post_ID' value='276838' id='comment_post_ID'/>
<input type='hidden' name='comment_parent' id='comment_parent' value='0'/>
</p></form>	</div><!-- #respond -->
	    </div> <!-- /.content -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar td_uid_5_60742f50ac66e_rand td_block_template_11 ">
<script type="text/javascript">var td_screen_width=window.innerWidth;if(td_screen_width>=1140){document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}if(td_screen_width>=1019&&td_screen_width<1140){document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}if(td_screen_width>=768&&td_screen_width<1019){document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}if(td_screen_width<768){document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409"></ins>');(adsbygoogle=window.adsbygoogle||[]).push({});}</script>
</div>

 <!-- end A --> 

<div class="td_block_wrap td_block_9 td_block_widget td_uid_6_60742f50ac842_rand td_with_ajax_pagination td-pb-border-top td_block_template_11 td-column-1 td_block_padding td_block_bot_line" data-td-block-uid="td_uid_6_60742f50ac842"><script>var block_td_uid_6_60742f50ac842=new tdBlock();block_td_uid_6_60742f50ac842.id="td_uid_6_60742f50ac842";block_td_uid_6_60742f50ac842.atts='{"custom_title":"Recent Posts","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m8_tl":"","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"26793, 26794, 26795, 26796","tag_slug":"","autors_id":"","installed_post_types":"","sort":"random_posts","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"next_prev","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_6_60742f50ac842_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m8f_title_font_header":"","m8f_title_font_title":"Article title","m8f_title_font_settings":"","m8f_title_font_family":"","m8f_title_font_size":"","m8f_title_font_line_height":"","m8f_title_font_style":"","m8f_title_font_weight":"","m8f_title_font_transform":"","m8f_title_font_spacing":"","m8f_title_":"","m8f_cat_font_title":"Article category tag","m8f_cat_font_settings":"","m8f_cat_font_family":"","m8f_cat_font_size":"","m8f_cat_font_line_height":"","m8f_cat_font_style":"","m8f_cat_font_weight":"","m8f_cat_font_transform":"","m8f_cat_font_spacing":"","m8f_cat_":"","m8f_meta_font_title":"Article meta info","m8f_meta_font_settings":"","m8f_meta_font_family":"","m8f_meta_font_size":"","m8f_meta_font_line_height":"","m8f_meta_font_style":"","m8f_meta_font_weight":"","m8f_meta_font_transform":"","m8f_meta_font_spacing":"","m8f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"td_uid_6_60742f50ac842_rand","tdc_css_class_style":"td_uid_6_60742f50ac842_rand_style"}';block_td_uid_6_60742f50ac842.td_column_number="1";block_td_uid_6_60742f50ac842.block_type="td_block_9";block_td_uid_6_60742f50ac842.post_count="3";block_td_uid_6_60742f50ac842.found_posts="141";block_td_uid_6_60742f50ac842.header_color="";block_td_uid_6_60742f50ac842.ajax_pagination_infinite_stop="";block_td_uid_6_60742f50ac842.max_num_pages="47";tdBlocksArray.push(block_td_uid_6_60742f50ac842);</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Recent Posts</span></h4></div><div id=td_uid_6_60742f50ac842 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2021/04/05/moderna-inc-mrna-has-started-clinical-trials-of-its-covid-19-coronavirus-vaccine-against-south-african-strain/" rel="bookmark" title="Moderna Inc. (MRNA) Has Started Clinical Trials of Its COVID-19 Coronavirus Vaccine Against South African strain">Moderna Inc. (MRNA) Has Started Clinical Trials of Its COVID-19 Coronavirus Vaccine Against South...</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/09/21/prophase-labs-inc-prph-completed-debt-financing-issuing-10-million-of-unsecured-notes/" rel="bookmark" title="ProPhase Labs Inc. (PRPH) Completed Debt Financing Issuing $10 Million of Unsecured Notes">ProPhase Labs Inc. (PRPH) Completed Debt Financing Issuing $10 Million of Unsecured Notes</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2021/01/15/blackrock-bkcc-stable-even-after-beating-results-twitter-twtr-snap-remained-falling-after-right-decision/" rel="bookmark" title="BlackRock (BKCC) Stable Even After Beating Results, Twitter (TWTR), SNAP Remained Falling After “Right Decision”">BlackRock (BKCC) Stable Even After Beating Results, Twitter (TWTR), SNAP Remained Falling After “Right...</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 --></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_6_60742f50ac842" data-td_block_id="td_uid_6_60742f50ac842"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" id="next-page-td_uid_6_60742f50ac842" data-td_block_id="td_uid_6_60742f50ac842"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block --><aside class="td_block_template_11 widget widget_text">			<div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br/>
<!-- upn ver resp --><br/>
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409" data-ad-format="auto" data-full-width-responsive="true"></ins><br/>
<script>(adsbygoogle=window.adsbygoogle||[]).push({});</script></p>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	<div class="td-footer-wrapper td-container-wrap td-footer-template-4 ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span12">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://www.uspostnews.com/"><img class="td-retina-data" src="http://uspostnews.com/wp-content/uploads/2019/02/3.png" data-retina="http://uspostnews.com/wp-content/uploads/2019/02/3.png" alt="" title="" width=""/></a></div><div class="footer-text-wrap">“US Post News” – one of the oldest and most authoritative news sites in America. It was established in 1992, journalists, photographers, correspondents, researchers came to the publication from the editorial offices of regional newspapers, drama theater, etc. They had no training, and they gained experience and skill in the process of work.<div class="footer-email-wrap">Contact us: <a href="mailto:ceo@uspostnews.com">ceo@uspostnews.com</a></div></div><div class="footer-social-wrap td-social-style-2"></div></div>            </div>
        </div>
    </div>
</div>
	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-top-container"><ul id="menu-top" class="td-subfooter-menu"><li id="menu-item-38" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-38"><a href="https://www.uspostnews.com/about-us/">About Us</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-39"><a href="https://www.uspostnews.com/our-team/">Our Team</a></li>
<li id="menu-item-40" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-40"><a href="https://www.uspostnews.com/contact-us/">Contact Us</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                                    </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv.com 2019
        Version: 9.5 (rara)
        Deploy mode: deploy
        
        uid: 60742f50b0ad2
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">.td-post-category{font-family:'Open Sans',arial,sans-serif;font-size:10px;font-weight:600;line-height:1;background-color:#222;color:#3b78b4!important;margin-right:5px;padding:3px 6px 4px;display:block;vertical-align:top}</style>

<script type="text/javascript">jQuery().ready(function(){if(typeof tdsDateFormat!=='undefined'){var tdBusinessDateTimestamp=Math.floor(new Date().getTime()/1000);var tdBusinessTodayDate=td_date_i18n(tdsDateFormat,tdBusinessDateTimestamp);jQuery('.td-business-demo-js-date-today').text(tdBusinessTodayDate);}});</script><link rel='stylesheet' id='gglcptch-css' href='https://www.uspostnews.com/wp-content/plugins/google-captcha/css/gglcptch.css?ver=1.60' type='text/css' media='all'/>
<script type='text/javascript' src='https://www.uspostnews.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.5' id='td-site-min-js'></script>
<script type='text/javascript' src='https://www.uspostnews.com/wp-includes/js/comment-reply.min.js?ver=5.7' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.uspostnews.com/wp-includes/js/wp-embed.min.js?ver=5.7' id='wp-embed-js'></script>
<script type='text/javascript' data-cfasync="false" async="async" defer="defer" src='https://www.google.com/recaptcha/api.js?render=explicit&#038;ver=1.60' id='gglcptch_api-js'></script>
<script type='text/javascript' id='gglcptch_script-js-extra'>//<![CDATA[
var gglcptch={"options":{"version":"v2","sitekey":"6LcMIlIaAAAAAGyRyDb4A9xA0GgMPem8j_JohOMz","error":"<strong>Warning<\/strong>:&nbsp;More than one reCAPTCHA has been found in the current form. Please remove all unnecessary reCAPTCHA fields to make it work properly.","disable":0,"theme":"light"},"vars":{"visibility":false}};
//]]></script>
<script type='text/javascript' src='https://www.uspostnews.com/wp-content/plugins/google-captcha/js/script.js?ver=1.60' id='gglcptch_script-js'></script>

<!-- JS generated by theme -->

<script>(function(){var html_jquery_obj=jQuery('html');if(html_jquery_obj.length&&(html_jquery_obj.is('.ie8')||html_jquery_obj.is('.ie9'))){var path='https://www.uspostnews.com/wp-content/themes/Newspaper/style.css';jQuery.get(path,function(data){var str_split_separator='#td_css_split_separator';var arr_splits=data.split(str_split_separator);var arr_length=arr_splits.length;if(arr_length>1){var dir_path='https://www.uspostnews.com/wp-content/themes/Newspaper';var splited_css='';for(var i=0;i<arr_length;i++){if(i>0){arr_splits[i]=str_split_separator+' '+arr_splits[i];}var formated_str=arr_splits[i].replace(/\surl\(\'(?!data\:)/gi,function regex_function(str){return' url(\''+dir_path+'/'+str.replace(/url\(\'/gi,'').replace(/^\s+|\s+$/gm,'');});splited_css+="<style>"+formated_str+"</style>";}var td_theme_css=jQuery('link#td-theme-css');if(td_theme_css.length){td_theme_css.after(splited_css);}}});}})();</script>


</body>
</html>