<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
    <title>Do Analysts Recommend You Should Buy CF Bankshares Inc. (CFBK) Stock? | US Post News</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://www.uspostnews.com/xmlrpc.php" />
    <meta property="og:image" content="https://www.uspostnews.com/wp-content/uploads/2019/03/1.jpg" /><link rel="icon" type="image/png" href="https://uspostnews.com/wp-content/uploads/2019/02/33551.jpg"><link rel="amphtml" href="https://www.uspostnews.com/2020/08/28/do-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock/amp/" /><meta name="generator" content="AMP for WP 1.0.60"/><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="US Post News &raquo; Feed" href="https://www.uspostnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="US Post News &raquo; Comments Feed" href="https://www.uspostnews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="US Post News &raquo; Do Analysts Recommend You Should Buy CF Bankshares Inc. (CFBK) Stock? Comments Feed" href="https://www.uspostnews.com/2020/08/28/do-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11.2.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.uspostnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.1.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- uspostnews.com is managing ads with Advanced Ads --><script>
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
						</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.uspostnews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://www.uspostnews.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=618b370f2556e74c489bd6592378277f' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Merriweather+Sans%3A400%2C700%2C800%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%2C800%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900%2C800&#038;ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://www.uspostnews.com/wp-content/themes/Newspaper/style.css?ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://www.uspostnews.com/wp-content/themes/Newspaper/includes/demos/business/demo_style.css?ver=9.5' type='text/css' media='all' />
<script type='text/javascript' src='https://www.uspostnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.uspostnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.uspostnews.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.uspostnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.uspostnews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Digging Through Nuveen Municipal 2021 Target Term Fund (NHA) Fundamentals' href='https://www.uspostnews.com/2020/08/28/digging-through-nuveen-municipal-2021-target-term-fund-nha-fundamentals/' />
<link rel='next' title='Are Nuveen AMT-Free Municipal Value Fund (NUW) Shares Headed For A Pullback?' href='https://www.uspostnews.com/2020/08/28/are-nuveen-amt-free-municipal-value-fund-nuw-shares-headed-for-a-pullback/' />
<meta name="generator" content="WordPress 5.1.6" />
<link rel="canonical" href="https://www.uspostnews.com/2020/08/28/do-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock/" />
<link rel='shortlink' href='https://www.uspostnews.com/?p=273876' />
<link rel="alternate" type="application/json+oembed" href="https://www.uspostnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.uspostnews.com%2F2020%2F08%2F28%2Fdo-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.uspostnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.uspostnews.com%2F2020%2F08%2F28%2Fdo-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock%2F&#038;format=xml" />
			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.uspostnews.com\/wp-admin\/","wpRestNonce":"d8744cd014","wpRestUrl":"https:\/\/www.uspostnews.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>
			<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
    
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>



<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.uspostnews.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.uspostnews.com/market/",
                    "name": "Market"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.uspostnews.com/2020/08/28/do-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock/",
                    "name": "Do Analysts Recommend You Should Buy CF Bankshares Inc. (CFBK) Stock?"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://www.uspostnews.com/wp-content/uploads/2019/02/33551.jpg" sizes="32x32" />
<link rel="icon" href="https://www.uspostnews.com/wp-content/uploads/2019/02/33551.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.uspostnews.com/wp-content/uploads/2019/02/33551.jpg" />
<meta name="msapplication-TileImage" content="https://www.uspostnews.com/wp-content/uploads/2019/02/33551.jpg" />

<!-- Button style compiled by theme -->

<style>
    .tdm-header-style-1.td-header-wrap .td-header-top-menu-full,
                .tdm-header-style-1.td-header-wrap .top-header-menu .sub-menu,
                .tdm-header-style-2.td-header-wrap .td-header-top-menu-full,
                .tdm-header-style-2.td-header-wrap .top-header-menu .sub-menu,
                .tdm-header-style-3.td-header-wrap .td-header-top-menu-full,
                .tdm-header-style-3.td-header-wrap .top-header-menu .sub-menu{
                    background-color: #005689;
                }
				
				
                .tdm-menu-active-style2 .tdm-header ul.sf-menu > .td-menu-item,
                .tdm-menu-active-style4 .tdm-header ul.sf-menu > .td-menu-item,
                .tdm-header .tdm-header-menu-btns,
                .tdm-header-style-1 .td-main-menu-logo a,
                .tdm-header-style-2 .td-main-menu-logo a,
                .tdm-header-style-3 .td-main-menu-logo a {
                    line-height: 36px;
                }
                .tdm-header-style-1 .td-main-menu-logo,
                .tdm-header-style-2 .td-main-menu-logo,
                .tdm-header-style-3 .td-main-menu-logo {
                    height: 36px;
                }
                @media (min-width: 767px) {
                    .tdm-header-style-1 .td-main-menu-logo img, 
                    .tdm-header-style-2 .td-main-menu-logo img, 
                    .tdm-header-style-3 .td-main-menu-logo img {
                        max-height: 36px;
                    }
                }
</style>

	<style id="tdw-css-placeholder"></style>	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-6166308950018215",
          enable_page_level_ads: true
     });
</script>
	<meta name="google-site-verification" content="MruR0mfZY8zxvYBu7-IUmyFX1gL2HJKLqCvoMI7d9EM" />
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-136511250-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-136511250-1');
</script>
</head>

<body class="post-template-default single single-post postid-273876 single-format-standard do-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock global-block-template-11 td-business td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Linkedin">
                <i class="td-icon-font td-icon-linkedin"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="#" title="Yahoo">
                <i class="td-icon-font td-icon-yahoo"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="td-mobile-main-menu"><li id="menu-item-33" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first menu-item-33"><a href="http://uspostnews.com/home/">Home</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="https://www.uspostnews.com/finance/">Finance</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="https://www.uspostnews.com/industry/">Industry</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="https://www.uspostnews.com/companies/">Companies</a></li>
<li id="menu-item-37" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-37"><a href="https://www.uspostnews.com/market/">Market</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://www.uspostnews.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <style>
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    </style>
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style multipurpose 3
-->


<div class="td-header-wrap tdm-header tdm-header-style-3 td-header-background-image">
            <div class="td-header-bg td-container-wrap "></div>
    
            <div class="td-header-top-menu-full td-container-wrap ">
            <div class="td-container td-header-row td-header-top-menu">
                
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="menu-top-container"><ul id="menu-top" class="top-header-menu"><li id="menu-item-38" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-38"><a href="https://www.uspostnews.com/about-us/">About Us</a></li>
<li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-39"><a href="https://www.uspostnews.com/our-team/">Our Team</a></li>
<li id="menu-item-40" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-40"><a href="https://www.uspostnews.com/contact-us/">Contact Us</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
    </div>    </div>

<!-- LOGIN MODAL -->
            </div>
        </div>
    
    <div class="td-header-menu-wrap-full td-container-wrap ">
        <div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
            <div class="td-container td-header-row td-header-main-menu">
                <div class="tdm-menu-btns-socials">
            <div class="header-search-wrap">
            <div class="td-search-btns-wrap">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
                <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>

            <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
                <form method="get" class="td-search-form" action="https://www.uspostnews.com/">
                    <div role="search" class="td-head-form-search-wrap">
                        <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                    </div>
                </form>
                <div id="td-aj-search"></div>
            </div>
        </div>
    
    
    </div>

<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
        		<a class="td-mobile-logo td-sticky-disable" href="https://www.uspostnews.com/">
			<img class="td-retina-data" data-retina="https://uspostnews.com/wp-content/uploads/2019/02/3-300x101.png" src="https://uspostnews.com/wp-content/uploads/2019/02/3-300x101.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-disable" href="https://www.uspostnews.com/">
			<img class="td-retina-data" data-retina="https://uspostnews.com/wp-content/uploads/2019/02/3-300x101.png" src="https://uspostnews.com/wp-content/uploads/2019/02/3-300x101.png" alt=""/>
			<span class="td-visual-hidden">US Post News</span>
		</a>
	    </div>
    <div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-first td-menu-item td-normal-menu menu-item-33"><a href="http://uspostnews.com/home/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-35"><a href="https://www.uspostnews.com/finance/">Finance</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-36"><a href="https://www.uspostnews.com/industry/">Industry</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-34"><a href="https://www.uspostnews.com/companies/">Companies</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-37"><a href="https://www.uspostnews.com/market/">Market</a></li>
</ul></div></div>
            </div>
        </div>
    </div>

            <div class="td-banner-wrap-full td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header td_uid_1_5f49059e082d6_rand td_block_template_11 ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-6166308950018215" data-ad-slot="3110990055"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6166308950018215" data-ad-slot="3110990055"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-6166308950018215" data-ad-slot="3110990055"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-6166308950018215" data-ad-slot="3110990055"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 


</div>                </div>
            </div>
        </div>
    </div>
            </div>

            
<div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-default ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.uspostnews.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Market" class="entry-crumb" href="https://www.uspostnews.com/market/">Market</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Do Analysts Recommend You Should Buy CF Bankshares Inc. (CFBK) Stock?</span></div></div>

        <div class="td-pb-row">
                                    <div class="td-pb-span8 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
    <article id="post-273876" class="post-273876 post type-post status-publish format-standard has-post-thumbnail hentry category-market tag-cf-bankshares-inc tag-cfbk tag-cfbk-stock tag-cfbk-stock-price tag-nasdaqcfbk" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://www.uspostnews.com/market/">Market</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Do Analysts Recommend You Should Buy CF Bankshares Inc. (CFBK) Stock?</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.uspostnews.com/author/kiel-taylor/">Kiel Taylor</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2020-08-28T12:30:00+00:00" >August 28, 2020</time></span>                                                        </div>

            </header>

        </div>

        

        <div class="td-post-content">

        <div class="td-post-featured-image"><a href="https://www.uspostnews.com/wp-content/uploads/2019/03/1.jpg" data-caption=""><img width="696" height="444" class="entry-thumb td-modal-image" src="https://www.uspostnews.com/wp-content/uploads/2019/03/1-696x444.jpg" srcset="https://www.uspostnews.com/wp-content/uploads/2019/03/1-696x444.jpg 696w, https://www.uspostnews.com/wp-content/uploads/2019/03/1-300x192.jpg 300w, https://www.uspostnews.com/wp-content/uploads/2019/03/1-768x490.jpg 768w, https://www.uspostnews.com/wp-content/uploads/2019/03/1-1024x654.jpg 1024w, https://www.uspostnews.com/wp-content/uploads/2019/03/1.jpg 1068w, https://www.uspostnews.com/wp-content/uploads/2019/03/1-658x420.jpg 658w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="1"/></a></div>
        <div class="uspos-amp-before-content" id="uspos-1835084092"><amp-ad width="100vw" height="320"
     type="adsense"
     data-ad-client="ca-pub-6166308950018215"
     data-ad-slot="2667943409"
     data-auto-format="rspv"
     data-full-width="">
  <div overflow=""></div>
</amp-ad></div><div class="uspos-before-content" style="" id="uspos-1427806783"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6166308950018215" 
data-ad-slot="3110990055" 
data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div><p>On Thursday, shares of CF Bankshares Inc. (NASDAQ:CFBK) marked $11.05 per share versus a previous $10.96 closing price. With having a 0.82% gain, an insight into the fundamental values of CF Bankshares Inc., investors would also find a great ally in the technical patterns of the stock movements showed in stock charts. CFBK showed a fall of -20.79% within its YTD performance, with highs and lows between $8.44 &#8211; $15.00 during the period of 52 weeks, compared to the simple moving average of -7.95% in the period of the last 200 days.</p>
<strong>CF Bankshares Inc. (CFBK) Analysis</strong>
<p>The present dividend yield for CFBK owners is set at 0, marking the return investors will get regardless of the company’s performance in the upcoming period. In addition, the growth of sales from quarter to quarter is recording 16.50%, hinting the company’s progress in the upcoming progress.</p><div class="uspos-amp-2-para" id="uspos-2024154185"><amp-ad width="100vw" height="320"
     type="adsense"
     data-ad-client="ca-pub-6166308950018215"
     data-ad-slot="2667943409"
     data-auto-format="rspv"
     data-full-width="">
  <div overflow=""></div>
</amp-ad></div><div class="uspos-content" id="uspos-2114298980"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6166308950018215" 
data-ad-slot="3110990055" 
data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div>
<p>In order to gain a clear insight on the performance of CF Bankshares Inc. (CFBK) as it may occur in the future, there are more than several well-rounded types of analysis and research techniques, while equity is most certainly one of the more important indicators into the company’s growth and performance. In this case, you want to make sure that the return on the present equity of 19.50% is enough for you to make a profit out of your investment. You may also count in the quick ratio of the company, currently set at so you would make sure that the company is able to cover the debts it may have, which can be easily seen in annual reports of the company.</p>
<p>Set to affect the volatility of a given stock, the average volume can also be a valuable indicator, while CFBK is currently recording an average of 6.72K in volumes. The volatility of the stock on monthly basis is set at 2.92%, while the weekly volatility levels are marked at 2.04%with -3.32% of loss in the last seven days.</p><div class="uspos-amp-4-para" id="uspos-935289043"><amp-ad width="100vw" height="320"
     type="adsense"
     data-ad-client="ca-pub-6166308950018215"
     data-ad-slot="2667943409"
     data-auto-format="rspv"
     data-full-width="">
  <div overflow=""></div>
</amp-ad></div>
<strong>What to Look for When Analyzing CF Bankshares Inc. Shares?</strong>
<p>CF Bankshares Inc. (CFBK) is based in the USA and it represents one of the well-known company operating with Financial sector. If you wish to compare CFBK shares with other companies under Electronic Equipment and Consumer Goods, a factor to note is the P/E value of 3.87 for CF Bankshares Inc., while the value can represent an indicator in the future growth of the company in terms of investor’s expectations. The later value should have a steady growth rate, increasing and growing gradually, which serves the purpose of reliably showcasing the progress of the company. The value 2.86 is supported by the yearly EPS growth of 103.30%.</p><div class="uspos-5th-para" id="uspos-1254952741"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6166308950018215" 
data-ad-slot="3110990055" 
data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div>
<p>Besides from looking into the fundamentals, you should also note the number of people inside the company owning the shares, as the values should be in line with the expectations of investors. In that spirit, the present ownership of stocks inside the company is set at 3.40%, which can provide you with an insight of how involved executives are in owning shares of the company. In oppose to the executives’ share, the institutional ownership counts 30.40% of shares, carrying an equal significance as an indicator of value, as the presence of large investors may signal a strong company.</p><div class="uspos-amp-6-para" id="uspos-593757762"><amp-ad width="100vw" height="320"
     type="adsense"
     data-ad-client="ca-pub-6166308950018215"
     data-ad-slot="2667943409"
     data-auto-format="rspv"
     data-full-width="">
  <div overflow=""></div>
</amp-ad></div>
<strong>Are Institutional Investors Increasing Stakes in CFBK Shares?</strong>
<p>It appears that more than several institutional investors and hedge funds decided to increase stakes in CFBK in the recent period. That is how AllianceBernstein LP now has an increase position in CFBK by 0.41% in the first quarter, owning 437790 shares of CFBK stocks, with the value of $4.65 million after the purchase of an additional 1,772 shares during the last quarter. In the meanwhile, Ancora Advisors LLC also increased their stake in CFBK shares changed &#8212; in the first quarter, which means that the company now owns 209636 shares of company, all valued at $2.23 million after the acquisition of additional 209,636 shares during the last quarter.</p><div class="uspos-content-2" style="" id="uspos-700339780"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6166308950018215" 
data-ad-slot="4008945238" 
data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div>
<p>Fifth Third Bank, NA acquired a new position in CF Bankshares Inc. during the first quarter, with the value of $1.22 million, and First Manhattan Co. increased their stake in the company’s shares by 70.53% in the first quarter, now owning 32,613 shares valued at $838176 after the acquisition of the additional 78850 shares during the last quarter. At the present, 30.40% of CFBK shares are in the ownership of institutional investors.</p>
<div class="uspos-after-content" id="uspos-1106016519"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-6166308950018215" 
data-ad-slot="3110990055" 
data-ad-format="auto"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</div><div class="uspos-amp-after-content" id="uspos-120950289"><amp-ad width="100vw" height="320"
     type="adsense"
     data-ad-client="ca-pub-6166308950018215"
     data-ad-slot="2667943409"
     data-auto-format="rspv"
     data-full-width="">
  <div overflow=""></div>
</amp-ad></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://www.uspostnews.com/tag/cf-bankshares-inc/">CF Bankshares Inc.</a></li><li><a href="https://www.uspostnews.com/tag/cfbk/">CFBK</a></li><li><a href="https://www.uspostnews.com/tag/cfbk-stock/">CFBK stock</a></li><li><a href="https://www.uspostnews.com/tag/cfbk-stock-price/">CFBK stock price</a></li><li><a href="https://www.uspostnews.com/tag/nasdaqcfbk/">NASDAQ:CFBK</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://www.uspostnews.com/2020/08/28/do-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.uspostnews.com%2F2020%2F08%2F28%2Fdo-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock%2F">
                                        <div class="td-social-but-icon"><i class="td-icon-facebook"></i></div>
                                        <div class="td-social-but-text">Facebook</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Do+Analysts+Recommend+You+Should+Buy+CF+Bankshares+Inc.+%28CFBK%29+Stock%3F&url=https%3A%2F%2Fwww.uspostnews.com%2F2020%2F08%2F28%2Fdo-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock%2F&via=US+Post+News">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-googleplus" href="https://plus.google.com/share?url=https://www.uspostnews.com/2020/08/28/do-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock/">
                                        <div class="td-social-but-icon"><i class="td-icon-googleplus"></i></div>
                                        <div class="td-social-but-text">Google+</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.uspostnews.com/2020/08/28/do-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock/&amp;media=https://www.uspostnews.com/wp-content/uploads/2019/03/1.jpg&description=Do+Analysts+Recommend+You+Should+Buy+CF+Bankshares+Inc.+%28CFBK%29+Stock%3F">
                                        <div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div>
                                        <div class="td-social-but-text">Pinterest</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Do+Analysts+Recommend+You+Should+Buy+CF+Bankshares+Inc.+%28CFBK%29+Stock%3F %0A%0A https://www.uspostnews.com/2020/08/28/do-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://www.uspostnews.com/2020/08/28/digging-through-nuveen-municipal-2021-target-term-fund-nha-fundamentals/">Digging Through Nuveen Municipal 2021 Target Term Fund (NHA) Fundamentals</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://www.uspostnews.com/2020/08/28/are-nuveen-amt-free-municipal-value-fund-nuw-shares-headed-for-a-pullback/">Are Nuveen AMT-Free Municipal Value Fund (NUW) Shares Headed For A Pullback?</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.uspostnews.com/author/kiel-taylor/">Kiel Taylor</a></span></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Kiel Taylor"></span><meta itemprop="datePublished" content="2020-08-28T12:30:00+00:00"><meta itemprop="dateModified" content="2020-08-28T12:30:00+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.uspostnews.com/2020/08/28/do-analysts-recommend-you-should-buy-cf-bankshares-inc-cfbk-stock/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://uspostnews.com/wp-content/uploads/2019/02/3-300x101.png"></span><meta itemprop="name" content="US Post News"></span><meta itemprop="headline " content="Do Analysts Recommend You Should Buy CF Bankshares Inc. (CFBK) Stock?"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.uspostnews.com/wp-content/uploads/2019/03/1.jpg"><meta itemprop="width" content="1068"><meta itemprop="height" content="682"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_3_5f49059e0bbcf_rand td_with_ajax_pagination td-pb-border-top td_block_template_11"  data-td-block-uid="td_uid_3_5f49059e0bbcf" ><script>var block_td_uid_3_5f49059e0bbcf = new tdBlock();
block_td_uid_3_5f49059e0bbcf.id = "td_uid_3_5f49059e0bbcf";
block_td_uid_3_5f49059e0bbcf.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_3_5f49059e0bbcf_rand","td_column_number":3,"live_filter_cur_post_id":273876,"live_filter_cur_post_author":"10","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_3_5f49059e0bbcf_rand","tdc_css_class_style":"td_uid_3_5f49059e0bbcf_rand_style"}';
block_td_uid_3_5f49059e0bbcf.td_column_number = "3";
block_td_uid_3_5f49059e0bbcf.block_type = "td_block_related_posts";
block_td_uid_3_5f49059e0bbcf.post_count = "3";
block_td_uid_3_5f49059e0bbcf.found_posts = "460";
block_td_uid_3_5f49059e0bbcf.header_color = "";
block_td_uid_3_5f49059e0bbcf.ajax_pagination_infinite_stop = "";
block_td_uid_3_5f49059e0bbcf.max_num_pages = "154";
tdBlocksArray.push(block_td_uid_3_5f49059e0bbcf);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_4_5f49059e0e2b7" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_3_5f49059e0bbcf" href="#">RELATED ARTICLES</a><a id="td_uid_5_5f49059e0e303" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_3_5f49059e0bbcf" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_3_5f49059e0bbcf class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.uspostnews.com/2020/08/28/lets-take-a-fresh-look-at-auburn-national-bancorporation-inc-aubn/" rel="bookmark" class="td-image-wrap" title="Let’s Take a Fresh Look at Auburn National Bancorporation, Inc. (AUBN)"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Let’s Take a Fresh Look at Auburn National Bancorporation, Inc. (AUBN)" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/02/4.jpg"  width="218" height="114" /></a></div>                <a href="https://www.uspostnews.com/market/" class="td-post-category">Market</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/28/lets-take-a-fresh-look-at-auburn-national-bancorporation-inc-aubn/" rel="bookmark" title="Let’s Take a Fresh Look at Auburn National Bancorporation, Inc. (AUBN)">Let’s Take a Fresh Look at Auburn National Bancorporation, Inc. (AUBN)</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.uspostnews.com/2020/08/27/digging-through-interstate-power-and-light-company-ipldp-fundamentals/" rel="bookmark" class="td-image-wrap" title="Digging Through Interstate Power and Light Company (IPLDP) Fundamentals"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="Digging Through Interstate Power and Light Company (IPLDP) Fundamentals" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/03/17-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://www.uspostnews.com/market/" class="td-post-category">Market</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/27/digging-through-interstate-power-and-light-company-ipldp-fundamentals/" rel="bookmark" title="Digging Through Interstate Power and Light Company (IPLDP) Fundamentals">Digging Through Interstate Power and Light Company (IPLDP) Fundamentals</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td-meta-info-hide td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://www.uspostnews.com/2020/08/27/at-current-price-is-it-too-late-to-buy-independence-holding-company-ihc/" rel="bookmark" class="td-image-wrap" title="At Current Price, Is It Too Late To Buy Independence Holding Company (IHC)?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC"alt="" title="At Current Price, Is It Too Late To Buy Independence Holding Company (IHC)?" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2017/06/images.jpg"  width="218" height="122" /></a></div>                <a href="https://www.uspostnews.com/market/" class="td-post-category">Market</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/27/at-current-price-is-it-too-late-to-buy-independence-holding-company-ihc/" rel="bookmark" title="At Current Price, Is It Too Late To Buy Independence Holding Company (IHC)?">At Current Price, Is It Too Late To Buy Independence Holding Company (IHC)?</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_3_5f49059e0bbcf" data-td_block_id="td_uid_3_5f49059e0bbcf"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_3_5f49059e0bbcf" data-td_block_id="td_uid_3_5f49059e0bbcf"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
                            </div>
                        </div>
                        <div class="td-pb-span4 td-main-sidebar" role="complementary">
                            <div class="td-ss-main-sidebar">
                                
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-sidebar td_uid_6_5f49059e0f8eb_rand td_block_template_11 ">
<script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:200px;height:200px" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<span class="td-adspot-title">- Advertisement -</span><ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-6166308950018215" data-ad-slot="2667943409"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

<div class="td_block_wrap td_block_9 td_block_widget td_uid_7_5f49059e0fb75_rand td_with_ajax_pagination td-pb-border-top td_block_template_11 td-column-1 td_block_padding td_block_bot_line"  data-td-block-uid="td_uid_7_5f49059e0fb75" ><script>var block_td_uid_7_5f49059e0fb75 = new tdBlock();
block_td_uid_7_5f49059e0fb75.id = "td_uid_7_5f49059e0fb75";
block_td_uid_7_5f49059e0fb75.atts = '{"custom_title":"Recent Posts","custom_url":"","block_template_id":"","header_text_color":"#","border_color":"#","accent_text_color":"#","m8_tl":"","limit":"3","offset":"","el_class":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"random_posts","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"next_prev","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_7_5f49059e0fb75_rand","separator":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m8f_title_font_header":"","m8f_title_font_title":"Article title","m8f_title_font_settings":"","m8f_title_font_family":"","m8f_title_font_size":"","m8f_title_font_line_height":"","m8f_title_font_style":"","m8f_title_font_weight":"","m8f_title_font_transform":"","m8f_title_font_spacing":"","m8f_title_":"","m8f_cat_font_title":"Article category tag","m8f_cat_font_settings":"","m8f_cat_font_family":"","m8f_cat_font_size":"","m8f_cat_font_line_height":"","m8f_cat_font_style":"","m8f_cat_font_weight":"","m8f_cat_font_transform":"","m8f_cat_font_spacing":"","m8f_cat_":"","m8f_meta_font_title":"Article meta info","m8f_meta_font_settings":"","m8f_meta_font_family":"","m8f_meta_font_size":"","m8f_meta_font_line_height":"","m8f_meta_font_style":"","m8f_meta_font_weight":"","m8f_meta_font_transform":"","m8f_meta_font_spacing":"","m8f_meta_":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"td_uid_7_5f49059e0fb75_rand","tdc_css_class_style":"td_uid_7_5f49059e0fb75_rand_style"}';
block_td_uid_7_5f49059e0fb75.td_column_number = "1";
block_td_uid_7_5f49059e0fb75.block_type = "td_block_9";
block_td_uid_7_5f49059e0fb75.post_count = "3";
block_td_uid_7_5f49059e0fb75.found_posts = "1933";
block_td_uid_7_5f49059e0fb75.header_color = "";
block_td_uid_7_5f49059e0fb75.ajax_pagination_infinite_stop = "";
block_td_uid_7_5f49059e0fb75.max_num_pages = "645";
tdBlocksArray.push(block_td_uid_7_5f49059e0fb75);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Recent Posts</span></h4></div><div id=td_uid_7_5f49059e0fb75 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/04/how-does-northfield-bancorp-inc-staten-island-ny-nfbk-stack-up-for-investors/" rel="bookmark" title="How Does Northfield Bancorp, Inc. (Staten Island, NY) (NFBK) Stack Up For Investors?">How Does Northfield Bancorp, Inc. (Staten Island, NY) (NFBK) Stack Up For Investors?</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/13/taking-an-updated-look-at-the-data-first-trust-senior-floating-rate-2022-target-term-fund-fiv/" rel="bookmark" title="Taking an Updated Look at the Data First Trust Senior Floating Rate 2022 Target Term Fund (FIV)">Taking an Updated Look at the Data First Trust Senior Floating Rate 2022 Target...</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_8 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/06/08/what-will-eventually-wobble-fennec-pharmaceuticals-fenc-gms-gms/" rel="bookmark" title="What Will Eventually Wobble Fennec Pharmaceuticals (FENC), GMS (GMS)">What Will Eventually Wobble Fennec Pharmaceuticals (FENC), GMS (GMS)</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>
            </div>

            
        </div>

        
	</div> <!-- ./td-block-span12 --></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_7_5f49059e0fb75" data-td_block_id="td_uid_7_5f49059e0fb75"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_7_5f49059e0fb75" data-td_block_id="td_uid_7_5f49059e0fb75"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block --><div class="td_block_wrap td_block_21 td_block_widget td_uid_8_5f49059e11c60_rand td-pb-border-top td_block_template_11 td-column-1"  data-td-block-uid="td_uid_8_5f49059e11c60" ><script>var block_td_uid_8_5f49059e11c60 = new tdBlock();
block_td_uid_8_5f49059e11c60.id = "td_uid_8_5f49059e11c60";
block_td_uid_8_5f49059e11c60.atts = '{"custom_title":"Most Popular","class":"td_block_widget td_uid_8_5f49059e11c60_rand","separator":"","custom_url":"","block_template_id":"","m16_tl":"","m16_el":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","limit":"5","offset":"","el_class":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m16f_title_font_header":"","m16f_title_font_title":"Article title","m16f_title_font_settings":"","m16f_title_font_family":"","m16f_title_font_size":"","m16f_title_font_line_height":"","m16f_title_font_style":"","m16f_title_font_weight":"","m16f_title_font_transform":"","m16f_title_font_spacing":"","m16f_title_":"","m16f_cat_font_title":"Article category tag","m16f_cat_font_settings":"","m16f_cat_font_family":"","m16f_cat_font_size":"","m16f_cat_font_line_height":"","m16f_cat_font_style":"","m16f_cat_font_weight":"","m16f_cat_font_transform":"","m16f_cat_font_spacing":"","m16f_cat_":"","m16f_meta_font_title":"Article meta info","m16f_meta_font_settings":"","m16f_meta_font_family":"","m16f_meta_font_size":"","m16f_meta_font_line_height":"","m16f_meta_font_style":"","m16f_meta_font_weight":"","m16f_meta_font_transform":"","m16f_meta_font_spacing":"","m16f_meta_":"","m16f_ex_font_title":"Article excerpt","m16f_ex_font_settings":"","m16f_ex_font_family":"","m16f_ex_font_size":"","m16f_ex_font_line_height":"","m16f_ex_font_style":"","m16f_ex_font_weight":"","m16f_ex_font_transform":"","m16f_ex_font_spacing":"","m16f_ex_":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"td_uid_8_5f49059e11c60_rand","tdc_css_class_style":"td_uid_8_5f49059e11c60_rand_style"}';
block_td_uid_8_5f49059e11c60.td_column_number = "1";
block_td_uid_8_5f49059e11c60.block_type = "td_block_21";
block_td_uid_8_5f49059e11c60.post_count = "5";
block_td_uid_8_5f49059e11c60.found_posts = "1933";
block_td_uid_8_5f49059e11c60.header_color = "";
block_td_uid_8_5f49059e11c60.ajax_pagination_infinite_stop = "";
block_td_uid_8_5f49059e11c60.max_num_pages = "387";
tdBlocksArray.push(block_td_uid_8_5f49059e11c60);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Most Popular</span></h4></div><div id=td_uid_8_5f49059e11c60 class="td_block_inner">
        <div class="td_module_16 td_module_wrap td-animation-stack td-meta-info-hide">
            <div class="td-module-thumb"><a href="https://www.uspostnews.com/2020/08/28/how-does-gores-metropoulos-inc-gmhi-stack-up-for-investors/" rel="bookmark" class="td-image-wrap" title="How Does Gores Metropoulos, Inc. (GMHI) Stack Up For Investors?"><img class="entry-thumb" src=""alt="" title="How Does Gores Metropoulos, Inc. (GMHI) Stack Up For Investors?" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/02/5-150x150.jpg"  width="150" height="150" /></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/28/how-does-gores-metropoulos-inc-gmhi-stack-up-for-investors/" rel="bookmark" title="How Does Gores Metropoulos, Inc. (GMHI) Stack Up For Investors?">How Does Gores Metropoulos, Inc. (GMHI) Stack Up For Investors?</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>

                <div class="td-excerpt">
                    On Thursday, shares of Gores Metropoulos, Inc. (NASDAQ:GMHI) marked $10.95 per share versus a previous $11.13 closing price. With having a -1.62% loss, an...                </div>
            </div>

        </div>

        
        <div class="td_module_16 td_module_wrap td-animation-stack td-meta-info-hide">
            <div class="td-module-thumb"><a href="https://www.uspostnews.com/2020/08/28/lets-take-a-fresh-look-at-auburn-national-bancorporation-inc-aubn/" rel="bookmark" class="td-image-wrap" title="Let’s Take a Fresh Look at Auburn National Bancorporation, Inc. (AUBN)"><img class="entry-thumb" src=""alt="" title="Let’s Take a Fresh Look at Auburn National Bancorporation, Inc. (AUBN)" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/02/4-150x150.jpg"  width="150" height="150" /></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/28/lets-take-a-fresh-look-at-auburn-national-bancorporation-inc-aubn/" rel="bookmark" title="Let’s Take a Fresh Look at Auburn National Bancorporation, Inc. (AUBN)">Let’s Take a Fresh Look at Auburn National Bancorporation, Inc. (AUBN)</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>

                <div class="td-excerpt">
                    On Thursday, shares of Auburn National Bancorporation, Inc. (NASDAQ:AUBN) marked $41.50 per share versus a previous $41.10 closing price. With having a 0.97% gain,...                </div>
            </div>

        </div>

        
        <div class="td_module_16 td_module_wrap td-animation-stack td-meta-info-hide">
            <div class="td-module-thumb"><a href="https://www.uspostnews.com/2020/08/28/is-highway-holdings-limited-hiho-dependable-investment-for-investors/" rel="bookmark" class="td-image-wrap" title="Is Highway Holdings Limited (HIHO) Dependable Investment For Investors?"><img class="entry-thumb" src=""alt="" title="Is Highway Holdings Limited (HIHO) Dependable Investment For Investors?" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/02/3-3-150x150.jpg"  width="150" height="150" /></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/28/is-highway-holdings-limited-hiho-dependable-investment-for-investors/" rel="bookmark" title="Is Highway Holdings Limited (HIHO) Dependable Investment For Investors?">Is Highway Holdings Limited (HIHO) Dependable Investment For Investors?</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>

                <div class="td-excerpt">
                    On Thursday, shares of Highway Holdings Limited (NASDAQ:HIHO) marked $2.70 per share versus a previous $2.74 closing price. With having a -1.46% loss, an...                </div>
            </div>

        </div>

        
        <div class="td_module_16 td_module_wrap td-animation-stack td-meta-info-hide">
            <div class="td-module-thumb"><a href="https://www.uspostnews.com/2020/08/28/heres-why-first-capital-inc-fcap-is-a-stock-to-set-your-sights-on/" rel="bookmark" class="td-image-wrap" title="Here’s Why First Capital, Inc. (FCAP) Is A Stock To Set Your Sights On"><img class="entry-thumb" src=""alt="" title="Here’s Why First Capital, Inc. (FCAP) Is A Stock To Set Your Sights On" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/02/2-150x150.jpg"  width="150" height="150" /></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/28/heres-why-first-capital-inc-fcap-is-a-stock-to-set-your-sights-on/" rel="bookmark" title="Here’s Why First Capital, Inc. (FCAP) Is A Stock To Set Your Sights On">Here’s Why First Capital, Inc. (FCAP) Is A Stock To Set Your Sights On</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>

                <div class="td-excerpt">
                    On Thursday, shares of First Capital, Inc. (NASDAQ:FCAP) marked $62.40 per share versus a previous $62.13 closing price. With having a 0.43% gain, an...                </div>
            </div>

        </div>

        
        <div class="td_module_16 td_module_wrap td-animation-stack td-meta-info-hide">
            <div class="td-module-thumb"><a href="https://www.uspostnews.com/2020/08/28/are-nuveen-amt-free-municipal-value-fund-nuw-shares-headed-for-a-pullback/" rel="bookmark" class="td-image-wrap" title="Are Nuveen AMT-Free Municipal Value Fund (NUW) Shares Headed For A Pullback?"><img class="entry-thumb" src=""alt="" title="Are Nuveen AMT-Free Municipal Value Fund (NUW) Shares Headed For A Pullback?" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/02/1-150x150.jpg"  width="150" height="150" /></a></div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/28/are-nuveen-amt-free-municipal-value-fund-nuw-shares-headed-for-a-pullback/" rel="bookmark" title="Are Nuveen AMT-Free Municipal Value Fund (NUW) Shares Headed For A Pullback?">Are Nuveen AMT-Free Municipal Value Fund (NUW) Shares Headed For A Pullback?</a></h3>
                <div class="td-module-meta-info">
                                                                                                </div>

                <div class="td-excerpt">
                    On Thursday, shares of Nuveen AMT-Free Municipal Value Fund (NYSE:NUW) marked $16.03 per share versus a previous $16.01 closing price. With having a 0.14%...                </div>
            </div>

        </div>

        </div></div> <!-- ./block --><aside class="td_block_template_11 widget widget_text">			<div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- upn ver resp --><br />
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6166308950018215"
     data-ad-slot="2667943409"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins><br />
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</aside>                            </div>
                        </div>
                            </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	<div class="td-footer-wrapper td-container-wrap td-footer-template-3 ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span4">
                <div class="td-footer-info"><div class="footer-logo-wrap"><a href="https://www.uspostnews.com/"><img class="td-retina-data" src="https://uspostnews.com/wp-content/uploads/2019/02/3-300x101.png" data-retina="https://uspostnews.com/wp-content/uploads/2019/02/3-300x101.png" alt="" title="" width="" /></a></div><div class="footer-text-wrap">“US Post News” – one of the oldest and most authoritative news sites in America. It was established in 1992, journalists, photographers, correspondents, researchers came to the publication from the editorial offices of regional newspapers, drama theater, etc. They had no training, and they gained experience and skill in the process of work.<div class="footer-email-wrap">Contact us: <a href="mailto:ceo@uspostnews.com">ceo@uspostnews.com</a></div></div><div class="footer-social-wrap td-social-style-2"></div></div>            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_7 td_block_widget td_uid_10_5f49059e172e1_rand td-pb-border-top td_block_template_11 td-column-1 td_block_padding"  data-td-block-uid="td_uid_10_5f49059e172e1" ><script>var block_td_uid_10_5f49059e172e1 = new tdBlock();
block_td_uid_10_5f49059e172e1.id = "td_uid_10_5f49059e172e1";
block_td_uid_10_5f49059e172e1.atts = '{"sort":"random_posts","custom_title":"Most Viewed","limit":"3","class":"td_block_widget td_uid_10_5f49059e172e1_rand","separator":"","custom_url":"","block_template_id":"","m6_tl":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","offset":"","el_class":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m6f_title_font_header":"","m6f_title_font_title":"Article title","m6f_title_font_settings":"","m6f_title_font_family":"","m6f_title_font_size":"","m6f_title_font_line_height":"","m6f_title_font_style":"","m6f_title_font_weight":"","m6f_title_font_transform":"","m6f_title_font_spacing":"","m6f_title_":"","m6f_cat_font_title":"Article category tag","m6f_cat_font_settings":"","m6f_cat_font_family":"","m6f_cat_font_size":"","m6f_cat_font_line_height":"","m6f_cat_font_style":"","m6f_cat_font_weight":"","m6f_cat_font_transform":"","m6f_cat_font_spacing":"","m6f_cat_":"","m6f_meta_font_title":"Article meta info","m6f_meta_font_settings":"","m6f_meta_font_family":"","m6f_meta_font_size":"","m6f_meta_font_line_height":"","m6f_meta_font_style":"","m6f_meta_font_weight":"","m6f_meta_font_transform":"","m6f_meta_font_spacing":"","m6f_meta_":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"td_uid_10_5f49059e172e1_rand","tdc_css_class_style":"td_uid_10_5f49059e172e1_rand_style"}';
block_td_uid_10_5f49059e172e1.td_column_number = "1";
block_td_uid_10_5f49059e172e1.block_type = "td_block_7";
block_td_uid_10_5f49059e172e1.post_count = "3";
block_td_uid_10_5f49059e172e1.found_posts = "1933";
block_td_uid_10_5f49059e172e1.header_color = "";
block_td_uid_10_5f49059e172e1.ajax_pagination_infinite_stop = "";
block_td_uid_10_5f49059e172e1.max_num_pages = "645";
tdBlocksArray.push(block_td_uid_10_5f49059e172e1);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Most Viewed</span></h4></div><div id=td_uid_10_5f49059e172e1 class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide">

        <div class="td-module-thumb"><a href="https://www.uspostnews.com/2020/06/16/are-crown-holdings-inc-cck-shares-headed-for-a-pullback/" rel="bookmark" class="td-image-wrap" title="Are Crown Holdings, Inc. (CCK) Shares Headed For A Pullback?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="" title="Are Crown Holdings, Inc. (CCK) Shares Headed For A Pullback?" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/03/11-100x70.jpg"  width="100" height="70" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/06/16/are-crown-holdings-inc-cck-shares-headed-for-a-pullback/" rel="bookmark" title="Are Crown Holdings, Inc. (CCK) Shares Headed For A Pullback?">Are Crown Holdings, Inc. (CCK) Shares Headed For A Pullback?</a></h3>            <div class="td-module-meta-info">
                                                                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide">

        <div class="td-module-thumb"><a href="https://www.uspostnews.com/2020/08/25/at-current-price-is-it-too-late-to-buy-oil-dri-corporation-of-america-odc/" rel="bookmark" class="td-image-wrap" title="At Current Price, Is It Too Late To Buy Oil-Dri Corporation of America (ODC)?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="" title="At Current Price, Is It Too Late To Buy Oil-Dri Corporation of America (ODC)?" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/03/footer_bg-100x70.jpg"  width="100" height="70" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/25/at-current-price-is-it-too-late-to-buy-oil-dri-corporation-of-america-odc/" rel="bookmark" title="At Current Price, Is It Too Late To Buy Oil-Dri Corporation of America (ODC)?">At Current Price, Is It Too Late To Buy Oil-Dri Corporation...</a></h3>            <div class="td-module-meta-info">
                                                                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_6 td_module_wrap td-animation-stack td-meta-info-hide">

        <div class="td-module-thumb"><a href="https://www.uspostnews.com/2020/07/14/how-does-ofg-bancorp-ofg-stack-up-for-investors/" rel="bookmark" class="td-image-wrap" title="How Does OFG Bancorp (OFG) Stack Up For Investors?"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAGQAAABGAQMAAAAASKMqAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABBJREFUKM9jGAWjYBQMKwAAA9QAAQWBn6cAAAAASUVORK5CYII="alt="" title="How Does OFG Bancorp (OFG) Stack Up For Investors?" data-type="image_tag" data-img-url="https://www.uspostnews.com/wp-content/uploads/2019/03/12-100x70.jpg"  width="100" height="70" /></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/07/14/how-does-ofg-bancorp-ofg-stack-up-for-investors/" rel="bookmark" title="How Does OFG Bancorp (OFG) Stack Up For Investors?">How Does OFG Bancorp (OFG) Stack Up For Investors?</a></h3>            <div class="td-module-meta-info">
                                                                            </div>
        </div>

        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->            </div>

            <div class="td-pb-span4">
                <div class="td_block_wrap td_block_10 td_block_widget td_uid_11_5f49059e1aa9d_rand td-pb-border-top td_block_template_11 td-column-1 td_block_padding td_block_bot_line"  data-td-block-uid="td_uid_11_5f49059e1aa9d" ><script>var block_td_uid_11_5f49059e1aa9d = new tdBlock();
block_td_uid_11_5f49059e1aa9d.id = "td_uid_11_5f49059e1aa9d";
block_td_uid_11_5f49059e1aa9d.atts = '{"custom_title":"Trending Now","limit":"3","class":"td_block_widget td_uid_11_5f49059e1aa9d_rand","separator":"","custom_url":"","block_template_id":"","m9_tl":"","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"","offset":"","el_class":"","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","f_header_font_header":"","f_header_font_title":"Block header","f_header_font_settings":"","f_header_font_family":"","f_header_font_size":"","f_header_font_line_height":"","f_header_font_style":"","f_header_font_weight":"","f_header_font_transform":"","f_header_font_spacing":"","f_header_":"","f_ajax_font_title":"Ajax categories","f_ajax_font_settings":"","f_ajax_font_family":"","f_ajax_font_size":"","f_ajax_font_line_height":"","f_ajax_font_style":"","f_ajax_font_weight":"","f_ajax_font_transform":"","f_ajax_font_spacing":"","f_ajax_":"","f_more_font_title":"Load more button","f_more_font_settings":"","f_more_font_family":"","f_more_font_size":"","f_more_font_line_height":"","f_more_font_style":"","f_more_font_weight":"","f_more_font_transform":"","f_more_font_spacing":"","f_more_":"","m9f_title_font_header":"","m9f_title_font_title":"Article title","m9f_title_font_settings":"","m9f_title_font_family":"","m9f_title_font_size":"","m9f_title_font_line_height":"","m9f_title_font_style":"","m9f_title_font_weight":"","m9f_title_font_transform":"","m9f_title_font_spacing":"","m9f_title_":"","m9f_cat_font_title":"Article category tag","m9f_cat_font_settings":"","m9f_cat_font_family":"","m9f_cat_font_size":"","m9f_cat_font_line_height":"","m9f_cat_font_style":"","m9f_cat_font_weight":"","m9f_cat_font_transform":"","m9f_cat_font_spacing":"","m9f_cat_":"","m9f_meta_font_title":"Article meta info","m9f_meta_font_settings":"","m9f_meta_font_family":"","m9f_meta_font_size":"","m9f_meta_font_line_height":"","m9f_meta_font_style":"","m9f_meta_font_weight":"","m9f_meta_font_transform":"","m9f_meta_font_spacing":"","m9f_meta_":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","css":"","tdc_css":"","td_column_number":1,"header_color":"","color_preset":"","border_top":"","tdc_css_class":"td_uid_11_5f49059e1aa9d_rand","tdc_css_class_style":"td_uid_11_5f49059e1aa9d_rand_style"}';
block_td_uid_11_5f49059e1aa9d.td_column_number = "1";
block_td_uid_11_5f49059e1aa9d.block_type = "td_block_10";
block_td_uid_11_5f49059e1aa9d.post_count = "3";
block_td_uid_11_5f49059e1aa9d.found_posts = "1933";
block_td_uid_11_5f49059e1aa9d.header_color = "";
block_td_uid_11_5f49059e1aa9d.ajax_pagination_infinite_stop = "";
block_td_uid_11_5f49059e1aa9d.max_num_pages = "645";
tdBlocksArray.push(block_td_uid_11_5f49059e1aa9d);
</script><div class="td-block-title-wrap"><h4 class="td-block-title"><span class="td-pulldown-size">Trending Now</span></h4></div><div id=td_uid_11_5f49059e1aa9d class="td_block_inner">

	<div class="td-block-span12">

        <div class="td_module_9 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/28/how-does-gores-metropoulos-inc-gmhi-stack-up-for-investors/" rel="bookmark" title="How Does Gores Metropoulos, Inc. (GMHI) Stack Up For Investors?">How Does Gores Metropoulos, Inc. (GMHI) Stack Up For Investors?</a></h3>
                
                <div class="td-module-meta-info">
                                                        </div>

            </div>

	        
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_9 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/28/lets-take-a-fresh-look-at-auburn-national-bancorporation-inc-aubn/" rel="bookmark" title="Let’s Take a Fresh Look at Auburn National Bancorporation, Inc. (AUBN)">Let’s Take a Fresh Look at Auburn National Bancorporation, Inc. (AUBN)</a></h3>
                
                <div class="td-module-meta-info">
                                                        </div>

            </div>

	        
        </div>

        
	</div> <!-- ./td-block-span12 -->

	<div class="td-block-span12">

        <div class="td_module_9 td_module_wrap td-meta-info-hide">

            <div class="item-details">
                                <h3 class="entry-title td-module-title"><a href="https://www.uspostnews.com/2020/08/28/is-highway-holdings-limited-hiho-dependable-investment-for-investors/" rel="bookmark" title="Is Highway Holdings Limited (HIHO) Dependable Investment For Investors?">Is Highway Holdings Limited (HIHO) Dependable Investment For Investors?</a></h3>
                
                <div class="td-module-meta-info">
                                                        </div>

            </div>

	        
        </div>

        
	</div> <!-- ./td-block-span12 --></div></div> <!-- ./block -->            </div>
        </div>
    </div>
</div>
	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-top-container"><ul id="menu-top-1" class="td-subfooter-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-38"><a href="https://www.uspostnews.com/about-us/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-39"><a href="https://www.uspostnews.com/our-team/">Our Team</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-40"><a href="https://www.uspostnews.com/contact-us/">Contact Us</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                                    </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->



    <!--

        Theme: Newspaper by tagDiv.com 2019
        Version: 9.5 (rara)
        Deploy mode: deploy
        
        uid: 5f49059e1e2c5
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
.td-post-category {
  font-family: 'Open Sans', arial, sans-serif;
  font-size: 10px;
  font-weight: 600;
  line-height: 1;
  background-color: #222222;
  color: #3b78b4 !important;
  margin-right: 5px;
  padding: 3px 6px 4px;
  display: block;
  vertical-align: top;
}
</style>

<script type="text/javascript">jQuery().ready( function() {
    if (typeof tdsDateFormat !== 'undefined') {
    
            // php time() equivalent - js deals in milliseconds and php in seconds
            var tdBusinessDateTimestamp = Math.floor(new Date().getTime() / 1000);
    
            // replace the date
            var tdBusinessTodayDate = td_date_i18n(tdsDateFormat, tdBusinessDateTimestamp);
            jQuery('.td-business-demo-js-date-today').text(tdBusinessTodayDate);
    }
});</script><script type='text/javascript' src='https://www.uspostnews.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=9.5'></script>
<script type='text/javascript' src='https://www.uspostnews.com/wp-includes/js/comment-reply.min.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://www.uspostnews.com/wp-includes/js/wp-embed.min.js?ver=5.1.6'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://www.uspostnews.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://www.uspostnews.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>



			<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
				<header>

				
					<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
					<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
				
				</header>
				<div class="tdw-content">

					
					<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">


						<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>


						<textarea class="tdw-css-writer-editor td_live_css_uid_1_5f49059e1e45f"></textarea>
						<div id="td_live_css_uid_1_5f49059e1e45f" class="td-code-editor"></div>


						<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5f49059e1e45f');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5f49059e1e45f");
                                    window.editor.$blockScrolling = Infinity;

                                    // 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
                                    editor.getSession().setUseWrapMode(true);
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>

					</div>
				</div>

				<footer>

					
						<a href="#" class="tdw-save-css">Save</a>
						<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>

					
					<div class="tdw-resize"></div>
				</footer>
			</div>
			
</body>
</html>